TrustNet Server’s PSU Blew Up

About an hour ago I noticed the server was off. On looking at it, the power supply was very hot. I thought the problem was that it got clogged with dust and shutdown. So I used some canned air on it, and gave it a good cleaning. Then I plugged it back in. That turned out to have been a bad idea.

The PSU made several loud exploding noises, and bright sparks could be seen inside. Pretty scary stuff since this happened the moment I plugged the cable in, so I had my hand right near the thing. Lights went out.

I unplugged the cable, and turned things back on. Fortunately, the UPS it was connected to survived fine. Inside the server nothing looks obviously burned up, but since this is an ATX case, the PSU provides power even when the computer is supposed to be off, so something might have got fried.

The server will remain down for some hours, as it’s late here and no shops are open. If I’m lucky, and only the PSU died then it’ll go back up as soon as I get a new one, otherwise it could unfortunately take a few days, as I may not be able to get replacement hardware on the same day.

TrustNet won’t be working while the server is broken. If you’re constantly getting errors, reset the scanner. It should fail to login and then shut up. The downtime will be credited towards your subscription when it comes back online.

Advertisements

One Response to TrustNet Server’s PSU Blew Up

  1. Lacy says:

    ZOMG I’m glad you’re ok!
    Take your time and get the system fixed the right way. We can live without trustnet for a few hours šŸ™‚
    *hugz*

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: